Chapter 13
Publishing Your Flash Files

In This Chapter

Reducing your movie’s size for fast download

Testing your Flash movies

Publishing Flash movies to . swf, HTML, and other formats
Using Publish Profiles

Posting your movie to your Web site

Exporting movie and image files

Creating movies that viewers can print

our Flash movie is completed. Now you need to publish it in its final
form — most likely an . swf file that you can post on your Web site.
In this chapter, we explain how to prepare a Flash movie for publishing and
help you determine the ideal publish settings for your needs. We also discuss
how to publish to other graphic file formats such as PNG, in case you want to
create a non-Flash site or use your material in another program. We cover all
the bases so that you can get your animation up and running.

The filenames of Flash-published movies end with the . swf suffix. The letters
SWEF originally stood for Shockwave Flash, but nobody uses that term for
Flash movies anymore, even though the letters remain the same. So we refer
to SWF files as Flash Player files, not Shockwave Flash files. Flash converts
your movie data into a highly compact and efficient form in an SWF file; the
SWF file contains only the information needed for playback of your movies.
In contrast, when you save your movies by choosing Filew>Save (or Filem>
Save As), they are saved with the . £1a suffix. They are saved in a format
that can be read by the Flash CS3 application, but not the Flash Player. The

. f1a file contains lots of information about layers, Library items, your video
source files, and so on, which you need when you are creating your movies
and which the Flash Player doesn’t need.
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Optimizing Movies for Fast Download

Throughout this book, we offer suggestions for designing a Flash movie with
speedy downloading in mind. In this section, we put the suggestions together
so that you can review your movie as a whole before you publish it.

Reducing your Flash Player file sizes is no longer so important because many
people now have high-speed Internet connections. But not everyone does. So
it still isn’t a bad idea to spend a little time thinking about shrinking the size
of your Flash movies.

Simplifying artwork

By simplifying the artwork in your movie, you can greatly reduce the size
of a Flash movie, thereby increasing its speed. Here are the most important
techniques:

v~ Use symbols for every object that appears more than once. You can
turn any object or group of objects into a symbol. Nest your symbols —
for example, turn an object into a symbol and then use it in a movie
clip or button. Remember that you can change the color of symbol
instances — you don’t need to create a new symbol. (Chapter 7
covers symbols in detail.)

v Group objects whenever possible. Groups are almost as efficient as
symbols. (Chapter 4 explains how to create groups.)

1 Use vector graphics rather than bitmaps when you can. When you
do use bitmaps, don’t animate them unless you need to. Bitmaps and
bitmap animation can increase your Flash Player file size and thus the
download time. However, with the rising adoption of broadband Internet
access, bitmaps are an increasingly important part of Flash projects,
including the sites referred to in this book, and now Photoshop files
can easily be imported into Flash. (Chapter 3 explains how to import
a bitmap.)

v Optimize curves (choose Modify~>Shape~>Optimize). You can optimize
curves to reduce the number of lines used to create a shape. This can
be tiresome on a large project, but if you really need to reduce the size
of your Flash movie, this may help. (Check out Chapter 4 for further
explanation.)

v~ Use solid lines rather than dashed, dotted, and other line types when
possible. Try to avoid custom line widths. (We explain line types in
Chapter 3.)

 Use the Pencil tool rather than the Brush tool whenever possible.
The Pencil tool uses fewer bytes in your movie.
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v Use the Web-safe color palette. Avoid custom colors. (Check out
Chapter 3 for the lowdown on colors.) Custom color definitions are
kept with the Flash Player file.

v Avoid using transparency when you don’t need it. Using transparency
doesn’t make your Flash file bigger, but it can slow down playback
because of the extra calculation required. (On the other hand, sometimes
transparency effects make your movie look really great.) See Chapter 7 to
find out about changing the transparency of the elements in your movie.

v~ Use solid fills rather than gradients. Gradients are more complex and
make the Flash Player file bigger. However, gradients are also key to the
Flash look that is so popular. They help to make vector graphics look
less flat.

Optimizing text
Text can consume lots of bytes. Here’s what you can do to reduce the byte bite:

1 Reduce the number of fonts and font styles (bold, italic) as much as
possible. Use simpler sans serif fonts if you can. You get the best results
file-size-wise with the device fonts (sans, serif, and typewriter), although
you might find these device fonts boring. Flash doesn’t need to store the
outlines of device fonts in the . swf file, so these take up fewer bytes.
And usually your Flash projects will look better if you don’t use too
many fonts — a useful rule in the graphic design world is to avoid using
more than three fonts in a design. (See Chapter 5 for more information
on fonts.)

v~ If you create text fields, limit the text and specify any restrictions
that you can in the Character Options dialog box. (Choose Window=>
Property=>Properties to open the Property inspector if it’s not already
open, and then click Character in the Property inspector to open the
Character Options dialog box.) For example, exclude unnecessary
character outlines, such as numbers.

Compressing sound

You can compress sounds to reduce the file size. When you compress individ-
ual sounds in the Sound Properties dialog box, you can fine-tune settings for
each individual sound in your movie. Later in this chapter, we review how to
compress sound when you publish a Flash movie. Use the MP3 format when-
ever possible because it compresses well. If you need more information on
compressing sounds, check out Chapter 11.
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Here are some other ways that you can reduce the size of your sound files:

v Adjust the sound’s Time In and Time Out points to prevent silent
areas from being stored in your . swf file.

v Reuse sounds by using different In and Out points and by looping
different parts of the same sound.

v Don’t loop streaming sound.

See Chapter 11 for more information on editing, looping, and streaming sound.

Animating efficiently

One of the most effective ways to reduce file size is to use tweens (see
Chapter 9). Frame-by-frame animation creates larger files. Keeping ani-
mation localized in one area also helps. Small animations (animations
where the objects don’t move much) produce smaller file sizes than
wide-area animations.

Testing Movies

Before publishing your movie, you should test it. The first step is to simply
play your animation, as we explain in Chapter 9. But playing the animation

on the Stage doesn’t provide you with enough information to determine prob-
lems caused by file size. To find those kinds of bugs, you have to use the Test
Movie command or test your movie in a browser. The following sections tell
you how to test both ways.

Flash CS3 is optimized for the tasks that you perform when creating a Flash
movie (such as drawing, adding keyframes, showing and hiding layers, and
typing ActionScript code). It’s not optimized for playing back your animation —
the Flash Player is optimized for that. Your . f£1a file contains lots of information
that you need when you're creating your movies but the Flash Player doesn’t
need. The Flash Player plays only . swf files, which you can create when you
choose Filec>Publish.

Using the Test Movie command

After playing your animation, you should use the Test Movie or Test
Scene command. Then you can use the Bandwidth Profiler (and other tools
described in the following steps) to provide estimates of downloading speed
so you can find bottlenecks that pause your animation. You can also see the
results of movie clips and all ActionScript code.
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Figure 13-1:
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If you're using movie clips, they won’t play when you choose Control=Play. To
see them play you must choose Control=>Test Movie or Control=>Test Scene.

To test a movie or scene, follow these steps:

1. Choose Control=~>Test Movie (or Test Scene).

Flash publishes your movie to an . swf file by using the current settings
in the Publish Settings dialog box (see the section “Publishing Flash
Movies,” later in this chapter) and opens a new window. You see your
animation run. You can change the settings in the Publish Settings dialog
box (choose Filer>Publish Settings) before using this command.

. Choose Views>Download Settings and choose a downloading speed

between that of a 14.4 modem (1.2 Kbps) to a T1 line (131.2 Kbps).

If you repeatedly change the download settings, you get a better sense
of their effect. To specify your own settings, choose Customize, and in
the Custom Modem Settings dialog box, enter the menu text that you
want to appear on the menu and the bit rate in bytes per second. Click
OK. Then open the Download Settings menu again and choose your
customized setting, which now appears on the menu.

. Choose Viewr>Bandwidth Profiler to see the graph that shows the

downloading performance.

The bandwidth profiler (as shown in Figure 13-1) displays the byte size
of each individual frame. Frames whose bars rise above the lower red
horizontal line cause loading delays.

. To see settings for any one frame, stop the movie by clicking the

frame’s bar.

To the left of the bandwidth profiler, Flash displays the movie’s statistics:
dimensions, frame rate, file size, movie duration, and the amount of ani-
mation to preload in frames and seconds. You also see the size of each
individual frame.

8066

picturetour, swf

Fr rate: 24.0 fr/sec

Duration. 844 fr (35.2 s)
Preload. 641 1 (26.7 3)

Bandwidth: 4800 B/s (200 B/fr)

Frame: 1

Movie:
Dim: G10 X 330 pixels

Size. 272 KB (279249 B)

Semings:

Stare:

b KB (b24/ Bl

Frames with bars above this line cause loading delays.
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5. Choose Viewr>Streaming Graph to see how the Flash movie streams
into a browser.

6. Choose View>Frame by Frame Graph to see which frames contribute
to delays.

A frame whose bar extends above the red line may cause a bottleneck
when the movie downloads at the connection speed you choose in Step
2. By default, Flash opens the SWF window in Streaming Graph mode.

7. Choose View~>Simulate Download if you want to see the Flash movie
play as if loading at the speed you choose in Download Settings in
Step 2.

8. To close the SWF window, click its Close button.
After you analyze your movie, you can go back and optimize it to eliminate

delays. A short delay in the first frame is usually acceptable, but significant
delays during the movie result in jerky animation or pauses.

If you have a long movie divided into scenes, you can save time by using the
Test Scene command instead of the Test Movie command.

Testing a movie in a Web browser

The final steps of testing a movie are publishing it and viewing it in a Web
browser. For a quick view, you can use the Publish Preview command. Flash
publishes your movie to an . swf file, creates the appropriate HTML file, and
opens the HTML file in your default browser. Viewing your Flash Player file in
a browser reveals how the browser will display the movie when you upload it
to a Web site.

Flash uses the current settings in the Publish Settings dialog box to create
the preview, including the types of file formats that you have selected.

To preview your movie in a browser, follow these steps:
1. Choose Filez>Publish Settings to open the Publish Settings dialog box.
Choose the desired file formats and publish settings, and then click OK.

See the “Publishing Flash Movies” section, later in this chapter, for more
information on the Publish Settings dialog box.

2. Choose File=>Publish Preview and choose the desired format from the
submenu.

Flash opens your browser and runs your movie.

3. Close your browser to end the preview.
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As with any Web page material, you need to consider the following when
testing a Flash Player file:

+* The browser that your audience is using: Preview your Flash Player file
in the current version of both Internet Explorer (IE) and Mozilla Firefox,
if possible. You should probably try out at least one earlier version of
Internet Explorer, too. And you should test it in Safari on a Mac. Okay,
so you probably won’t do all this, but don’t say that we didn’t tell you.

v~ The resolution of viewers’ screens: Test at least the following common
settings: 800 x 600 and 1024 x 768. Remember that the amount of material
that appears on the screen changes with the resolution. If you preview at
640 x 480, you can be sure that people with higher resolutions can see
your entire movie, but then again, a Flash movie that fits in a 640 x 480
screen may look pretty humble on a 1280 x 1024 screen.

1 The color settings of viewers’ screens: Color settings might range from
256 colors to 16 million. If you aren’t using Web-safe colors, some view-
ers might not see them accurately. But the vast majority of viewers now
have thousands or millions of colors, which means that it’s not so
important to test that your movie looks good with fewer colors.

Professional Web site developers take this testing phase seriously. No matter
how good an animation looks on your screen, it’s not a good animation if it
doesn’t translate well to your target number of viewers’ screens.

Saving Vour Work in Flash 8 Format

\NG/
$

If you're collaborating on a Flash project with a group of friends or co-workers
and they’re still using Flash 8 (the predecessor of Flash CS3), there is still
hope for them. You can save your work in Flash 8 format.

To save your work in Flash 8 format, follow these steps:

1. Choose File=>Save As.
The Save As dialog box appears.

2. Choose where you want to save your file and then type the filename
you want to use.

3. Click the Format drop-down list and select Flash 8.
4. Click Save.

If you're using features new to Flash CS3, a window appears, listing the
new features that won’t be saved in the Flash 8 file and asking whether
you want to continue. Click the Save as Flash 8 button if you want to
continue. If you do so, some of the data in your file will not be available
in this saved version. So be sure to save a CS3 version as well to keep all
your data intact.
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Publishing Flash Movies

|
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So you're finally ready to publish your Flash masterpiece. It’s time to choose
Filew>Publish Settings. This brings you to the Publish Settings dialog box.
Don’t be overwhelmed by all the options. Usually, you use only a few of them.
Start by specifying the settings. Then publish the movie to create the . swf
file viewed on a Web page.

After you specify the settings, you can click OK rather than Publish if you
want to go back to your Flash movie file and choose Control=>Test Movie to
see the results of your settings. You can try various settings until you're satis-
fied. Then click Publish to create the final SWF (Flash Player) file. Published
files are in the same folder as your FLA movie file by default; you can specify
another location if you want. Of course, you can also move the files afterward.

The Publish Settings dialog box lets you easily specify all your settings in one
place. Then you click the Publish button, and Flash creates the SWF (Flash
Player) file according to your settings. Choose Filec>Publish Settings to open
the Publish Settings dialog box with the Formats tab on top, as shown in
Figure 13-2.

Publish Settings

Current profile: | Bounce Publish Profile _:] EREREEICIE]

Formats | Flash | HTML

Type: File:

@ Flash (.swf) bounce.swt
¥ HTML (html) bounce.html
| GIF Image (.gif} bounce.gif
| JPEG Image (|pg) hounee jpg
CIPNG Image (_png) hounce png
| Windows Projector (.exe) bounce.exe
| Macintosh Projector bounce.app

! QuickTime with Flash Track {.mov) bounce.mov

Use Default Names

(_ Publish ) ( Cancel ) f'—'@ﬁ'—)
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Flash automatically names the files that it creates for you, using the Flash
movie’s name and adding the appropriate file extension, such as .html and
.swf. You can see the names in the Formats tab of the Publish Settings dialog
box. To specify your own name for a file, click the File text box and type the
new name. To revert to the default filenames, click the Use Default Names
button.

Most of the time, you need only the Flash (. swf) and HTML formats. But if
you want other formats, select them on the Formats tab. When you mark an
additional format, the dialog box adds a new tab for that format (except for
the projector formats, which don’t need one).

After you mark the formats you want, click each tab to specify the settings
for that format. The next few sections of this chapter explain each format,
why you might want to use it, and how to specify the settings.

After you finish specifying all your settings, click the Publish button, and
Flash does your bidding, creating the files that you need to put your great
creation on the Web.

Publishing to SWF

The second tab in the Publish Settings dialog box (choose Filem>Publish
Settings) is the Flash tab, which creates the Flash Player file, also called an
.swf file. On this tab, shown in Figure 13-3, you specify settings that affect
the . swf file.

Flash gives you the following options:

v Version: Allows you to save in previous version formats for backward
compatibility (or in the Flash Lite format for playing Flash movies on
mobile phones, but that’s a subject for another book). If you use new
features but choose an old Flash Player version, Flash warns you of
potential problems when you publish your movie.

v Load Order: Specifies how Flash displays the first frame of the Flash
movie. Bottom Up (the default) loads layers from the lowest layer
upward. Top Down loads layers starting from the top layer and moving
downward. Your viewers will see the difference between these two set-
tings only if the Flash movie is loading slowly (because of a slow Internet
connection, for example). Because faster Internet access speeds are
becoming increasingly common, you may not need to worry about this.
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Publish Settings

Current profile: Bounce Publish Profile _:] EREREEICIE]

Formats | Flash | HTML
Version: | Flash Player 9 %]

I nad arder ~ Rommom up (- )

ActionScript version: | ActionScript 3.0 |5 Settings...

Options: !?Generate size report
! Protect from import
) Omit trace actions
| Permit debugging
E Comprass movie

" Export hidden layers

| Export SWC
Fassword:
Script time limit: 15 seconds
 eo—— e
JPEG quality: | o , 50
0 100
Audio stream: MP3, 16 kbhps, Mono Set... )
Audio event: MP3, 16 kbps, Mono PrSet—)

| Override sound secttings

) Export device sounds

Local playback security. | Access local files only _:]

Publish ) ( Cancel | 0K a

v ActionScript Version (for Flash Player 6, 7, 8, and 9, and Flash Lite 2.0

and 2.1 only): Specifies whether your movie is using ActionScript 1.0,
2.0, or 3.0. ActionScript 2.0, which was introduced in 2003, added new
commands to ActionScript that are mostly of interest to intermediate
or advanced programmers who are building applications in Flash that
implement new classes and subclasses of objects. ActionScript 3.0

is new in Flash CS3. Fundamental changes in the underpinnings of
ActionScript in version 3.0 make it possible for ActionScript 3.0 code
to execute up to ten times faster than code from earlier versions.

In this book, we use the new methods for handling events and other
new methods of ActionScript 3.0, so generally you will want to choose
ActionScript version 3.0 in the ActionScript Version drop-down list. You
can try choosing ActionScript 1.0 in the ActionScript Version drop-down
list and an earlier version of the Flash Player (such as Flash 5 or Flash 6)
in the Version drop-down list, and then see whether you get a warning
when you publish your movie. If you don’t get a warning, your published
movie will safely play on older versions of Flash, and thus may reach a
larger audience.
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1 Generate Size Report: Creates a . txt file that you can use to trouble-

shoot problem areas. The report relates the various parts of your movie
to the number of bytes that they require in the . swf file.

The size report can be more useful than the bandwidth profiler in
pinpointing the location of the giant-size parts of a movie. It’s worth
reviewing, and it’s interesting (and often surprising) to see the size of
the various elements of the . swf file.

v Protect from Import: Prevents the . swf files from being downloaded

from the Web site and imported back into Flash. This feature doesn’t
provide 100-percent-guaranteed protection, but it helps keep your work
from being “borrowed.”

+* Omit Trace Actions: Omits special codes used by programmers.

Trace actions insert into Flash movies the codes used to record and
display technical information about a Flash movie’s progress in a
special window, named the Flash Debugger. Programmers use this
information to debug (remove errors from) their ActionScript program-
ming. If you added Trace actions to your Flash movie, select the Omit
Trace Actions check box to omit these codes from the . swf file, and
your file will be smaller.

v Permit Debugging: Lets you use the Debugger to debug a Flash movie

from another computer. If you permit debugging, you can add a password
to protect the movie file. Although this option is useful for ActionScript
programmers, discussing it is beyond the scope of this book.

v Compress Movie: Compresses your Flash Player file, especially text and

ActionScript, so that it can download faster. This option is great except
that your compressed file does not play in Flash Player versions earlier
than Flash Player 6.

Your Flash movie probably uses some feature that’s been added to Flash
after Flash Player 5 anyway, so you might as well go for it and compress
your movie.

v Optimize for Flash Player 6 r65: This option appears if you choose

Flash Player 6 when you choose the Flash Player version at the top of
the dialog box. Flash Player 6 r65 was an updated version of Flash Player
with significant bug fixes and performance enhancements.

v~ Export Hidden Layers: This option is set by default. If you deselect this

option, Flash will not publish layers (including layers inside movie clips)
that are marked as hidden. Deselecting this option can be useful
because then you can test different versions of your document simply
by hiding layers.
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v Export SWC: If you're new to Flash, you can safely leave this option dis-
abled. SWC files are packages of precompiled components. Components
in Flash can be implemented either in an . £1a file or an . swc file. The
User Interface components (such as CheckBoxes, ComboBoxes and
RadioButtons) are implemented as FLA-based components, and the
FLVPlayback and FLVPlaybackCaptioning components are SWC-based.
You can use ActionScript to add SWC-based components while a Flash
Player movie is running so that they can be kept in . swc files that are
separate from your Flash Player file. Because . swc files contain precom-
piled components, the components appear faster than ordinary movie
clips. If you enable this option, when you publish your file, Flash creates
an . swc file that contains your SWC components and an . swf file that
uses the . swc file.

v Password: Allows you to select a password for debugging, if you enable
the Debugging Permitted (or Protect from Import) check box. This
option prevents viewers from debugging (or importing) the movie unless
they have the password.

v Script Time Limit: If a Flash movie seems to be stuck in an endless loop,
after 15 seconds the Flash Player will present the user with dialog box
asking whether to continue or quit. Here you can set the limit to a time
other than the default of 15 seconds.

v JPEG Quality: Sets the compression (size) versus quality of bitmaps, if
you have any in your movie. You can set the quality anywhere from 0
(the lowest quality and highest compression) to 100 (the highest quality
and lowest compression).

v Audio Stream: Displays and sets the audio compression for stream
sounds (sounds that use the Stream Sync setting in the Property
inspector when a frame with the sound is selected). This setting applies
if you haven’t set the compression for individual sounds in the Sound
Properties dialog box. Also, if you enable the Override Sound Settings
check box in the Publish Settings dialog box, this setting overrides the
setting in the Sound Properties dialog box. To change the current set-
ting, click Set. The options are the same as in the Sound Properties
dialog box. (Turn to Chapter 11 for details on setting sound properties.)

v Audio Event: Displays and sets the audio compression for event sounds
(as set in the Property inspector when a frame with the sound is
selected). Otherwise, the compression setting is the same as Audio
Stream.

1 Override Sound Settings: Select this option to override settings in the
Sound Properties dialog box. Then the settings here apply to all sounds
in your movie.

v Export Device Sounds: This gives you the option of exporting sounds in
formats suitable for playback on mobile devices, such as certain mobile
phones and personal digital assistants (PDAs). To do this, you use proxy
sound files, a discussion of which is beyond the scope of this book.
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v Local Playback Security: If you select Local Access Only, your Flash
movie can interact only with files and resources on the computer
that it’s playing on. If you select Access Network Only, your movie can
interact only with files and resources on the network, and not with those
on the computer it’s playing on. (This separation of local and network
access helps make it more difficult for a malicious programmer to create
a Flash file that collects data from your computer and transmits it over a
network such as the Internet.)

If all these settings seem like a bit much, you can always just use the default
settings, go with the flow, and check the results.

Publishing to HTML

HTML is the basic language of Web pages. If you work on a Web site, you can
write the HTML code from scratch or use an HTML editor. However, many
people use a Web authoring program, such as Dreamweaver.

To place a Flash Player file on a Web page, you need the proper HTML code.
You probably also want some sophisticated JavaScript code in the Web page
that takes care of recent changes in Internet Explorer so that your Flash
movies will activate automatically, without first requiring that the user
respond to a prompt for a click. (JavaScript is a programming language that
is designed to give Web pages capabilities far beyond what HTML can do.)
Luckily, Flash can create all this code for you, in formats suitable for most
browsers.

As the result of a patent lawsuit, in 2006 Microsoft released an updated ver-
sion of Internet Explorer that prompts the user with a request for a confirma-
tion click for each Flash file, QuickTime movie, and other Active X control in
each Web page, to confirm that the user wants to activate it. Yikes!

Understanding the HTML code for a movie

Figure 13-4 shows the type of HTML code and JavaScript code that Flash
generates when you publish your Flash file by using default settings, as
displayed in TextEdit on a Mac. (In TextEdit, before opening your HTML
file, be sure to choose TextEdit=>Preferences and then select the Plain Text
option in the New Document Attributes section of the Preferences dialog
box.) Windows users can use Notepad to view HTML code created by the
Publish command.
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If you know some HTML, some parts of this page will look fairly familiar. (And
if you don’t, you might want to check out HTML 4 For Dummies, 5th Edition,
by Ed Tittel and Mary Burmeister, from Wiley Publishing, Inc.) The page
starts with the tags (codes) that all HTML documents contain, namely
<html>, <head>, <title>, and <body>. Here’s how to understand the

code in Figure 13-4:

v After <body, you see bgcolor="#ffffff">. This is the background

color of the entire HTML page.

By default, Flash makes the background color of the HTML page the
same color as the background of your Flash movie, but you might prefer
to change it to a different color to help visually define the Flash movie.

v After the comments (which start with <!) is JavaScript code between the
<script language="javascript"> tagand the </script> tag. This
code is used by another JavaScript file (named AC_RunActiveContent.
js) created by Flash when you publish your Flash movie. The JavaScript
code writes HTML code that your Web browser will display. So the
JavaScript code creates the HTML code that creates the Web page that

you end up seeing.

v After the </script> tag, you see a <noscript> tag. All the code after
the <noscript> tag is the HTML for the Web page that will appear if

users have JavaScript turned off in their browser.

N —— ]
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v Next you see the object tag. Microsoft Internet Explorer requires this tag
to display your Flash Player files. The object code includes the following:

¢ Detailed codes (which are required to tell Internet Explorer how to
display your player file).

¢ The specification of the version of the Flash viewer to look for and
where to download it if necessary.

¢ The width and height of the Flash movie in the browser.
¢ The name of the file (value="Movie of the Year.swf").

e Parameter settings for local or network access, looping, quality,
and background color. You set the background color by choosing
Modify=>Document in Flash and choosing a background color in
the Document Properties dialog box. (See Chapter 2 for details on
using this dialog box.)

¢ The embed code is for Netscape Navigator, Mozilla, and Mozilla
Firefox browsers, and accomplishes the same thing as the
object code.

v Finally, you see the closing </object> tag, the closing </noscript> tag,
and the tags that end every HTML document: </body> and </html>.

If you want to use the HTML document as is, you can. But if you want to com-
bine your Flash Player file with the elements in another HTML file (as you
would for a Flash button, for example), you need to combine the code in the
two documents.

One way you can do this is to treat as one unit all the code in the first docu-
ment (the HTML document created in Flash when you choose Filem>Publish),
starting with <script language="javascript"> and ending with
</script>, which is the tag immediately before the <noscript> tag. Think
of this unit as your Flash movie code. Then copy HTML from your second
HTML document and paste it before or after your unit of Flash movie code,
to display HTML elements before or after your Flash movie.

If you didn’t change your default folder locations in the Formats section

of the Publish Settings dialog box, your . swf file will be in the same folder

as the HTML file that Flash creates when you publish your movie. In that
case, the HTML <object> and <embed> tags created by the Flash publishing
process reference the . swf file by simply mentioning the filename. For that
to work, the . swf file must be in the same folder on your Web site’s server
as your Web page’s HTML file.

If you usually keep image files in a subfolder and want to also place your
.swf file in that subfolder, you can specify that location in the Formats tab
of the Publish Settings dialog box. Click the small folder icon to the right of
the name of the . swf file, and navigate to the subfolder where you want it
to be placed.
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Specifying Flash Player detection and
other HTML settings

To create the HTML file, you need to specify the HTML settings on the HTML
tab of the Publish Settings dialog box, as shown in Figure 13-5.

Publish Settings
Current profile: | Bounce Publish Profile 3 EREREEICIE]

Formats _ Flash | HTML }
) (

Template:  Flash Only Into

@ Detect Flash Version

Version: 9 . 0 . |0
Dimensions: = Match Movie _i]
Width: Height
X pixels
Playback: ] Paused at start ™ Display menu
4 Loop ! Device font
Quality: | High =3
Window Mode: = Window _ﬂ
HIML alignment: | Default _ﬂ
Scale: | Default (Show all) _:1
Horizontal: Vertical:
Flash alignment | Cenrer :I Center ! :]

™ show WArning messdages

{_ Publish [ Cancel )

ok )

Template

The first setting, Template, lets you select a template. The template deter-
mines the format and contents of the HTML file. To keep matters simple,
select the default, Flash Only. Table 13-1 explains the other template options,
although it’s very possible that you may never need to use anything other
than the default, Flash Only.
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Table 13-1

HTML Template Options

Option

What It Does

Flash for Pocket
PC 2003

Creates an HTML file with <object> and <embed>
tags and with Pocket PC—specific alignment. Can be used
with Pocket IE and with desktop Internet Explorer and
Netscape browsers.

Flash HTTPS

Creates an HTML file with JavaScript code that displays
your Flash movie without requiring a user to first respond
to a prompt. Uses the HTTPS protocol to specify where to
go to download the Flash Player if necessary. HTTPS is
designed to send data over the Web more securely than
the standard method (HTTP). Also creates a JavaScript
file in your HTML output folder, and this must be uploaded
along with the HTML file.

Flash Only (Default)

Creates an HTML file with JavaScript code that displays
your Flash movie without requiring a user to first respond
to a prompt. Also creates a JavaScript file in your HTML
output folder, and this must be uploaded along with the
HTML file.

Flash with AICC
Tracking

Includes support for AICC-HACP tracking when using
Macromedia Learning Interactions. (AICC is Aviation
Industry Computer-Based-Training Committee, and HACP
is HTTP AICC Communications Protocol.)

Flash with
FSCommand

Used when you have added an FSCommand action to
your movie to interface with JavaScript. The HTML file
also includes the <object> and <embed> commands.

Flash with Full
Screen Support

Creates an HTML file with JavaScript code that displays
your Flash movie without requiring a user to first respond
to a prompt. Includes support for playing your Flash
movie full screen. Also creates a JavaScript file in your
HTML output folder, and this must be uploaded along with
the HTML file.

Flash with Named
Anchors

Creates an HTML file with <object> and <embed>
tags. Adds browser scripting and HTML anchors so that
viewers can bookmark Flash content in Flash Player 6
and later, and thus use the Web browser’s Back button
effectively while navigating within a Flash movie.

This could be a great feature, but many browsers don’t
support it, so it’s fairly useless.

(continued)
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Table 13-1 (continued)

Option What It Does

Flash with SCORM Includes support for SCORM (Sharable Content Object

1.2 Tracking Reference Model) version 1.2 tracking when using
Macromedia Learning Interactions.

Flash with SCORM Includes support for SCORM 2004 tracking when using

2004 Tracking Macromedia Learning Interactions.

Image Map (If you don’t know what an image map is, don't worry

about this option.) Instead of displaying an SWF player
file, uses a GIF, JPEG, or PNG image (which you need to
choose in the Formats tab) as a client-side image map
coded in your HTML page.

QuickTime Creates <embed> and <object> tags in an HTML

page to display a QuickTime Flash movie based on your
Flash movie. You need to select the QuickTime check box
on the Formats tab. A QuickTime Flash movie plays with
only QuickTime 4 or later. QuickTime 4 can recognize only
Flash 3 features. QuickTime 5 can recognize Flash 4 fea-
tures. (QuickTime 4 and 5 are old, so this isn't an interest-
ing way to publish your Flash movies.)

Below the Template drop-down list is the Detect Flash Version check box.
(This option is available only if you choose Flash Player 4 or later in the Flash
tab of the Publish Settings dialog box and the Flash HTTPS or Flash Only
template.) Select this check box to add browser scripting to detect the Flash
Player for the version of Flash you specify on the Flash tab. When this check
box is enabled, the Version number text boxes below it are also enabled.

If you want to more exactly specify the minimum version required, type
revision numbers in the Minor Revision and Incremental Revision text fields
there. (Minor Revision and Incremental Revision appear in tooltips when you
move the mouse cursor over the text boxes.)

If you select the Detect Flash Version check box, when you publish your Flash
file, the resulting HTML code prints “Alternate HTML content should be placed
here” in your Web page if the Flash Player of the specified version can’t be
found or if the Web browser doesn’t have scripting enabled. (Scripting must

be enabled by the Web browser for the Flash Player version detection to work.)
You can edit the HTML to replace the sentence “Alternate HTML content
should be placed here” with whatever alternative content you want to display
when the Flash Player version can’t be found.
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Dimensions

The Dimensions options control the size allotted to your Flash Player movie
on your Web page. You have three options:

v Match Movie matches the width and height that you set in the Movie
Properties dialog box (choose Modify=>Document).

v~ Pixels lets you specify the Width and Height in pixels. Type the desired
values in the text boxes.

v Percent lets you specify the area used by the Flash Player movie as a
percentage of the browser window size. The 100% setting is ideal for
pages designed to take up the entire page. Type the desired percentage
values in the text boxes labeled Width and Height.

Playback

The Playback section determines the values of parameters in the HTML code.
You have four options:

1 Paused at Start creates a PLAY parameter whose value is FALSE. The
person must start the movie by clicking a button in the movie — the
button’s instance needs to have a Play action in it. Alternatively, viewers
can right-click (Windows) or Control+click (Mac) the movie and choose
Play in the shortcut menu, but they might not be aware of this. By default,
this check box is deselected, so movies start to play automatically.

v Loop creates a LOOP parameter whose value is TRUE. The movie repeats
over and over. By default, this check box is selected, so make sure to
clear it if you don’t want to loop your movie!

v~ Display Menu creates a MENU parameter set to TRUE. This option
enables viewers to right-click (Windows) or Control+click (Mac) the
movie and choose from a menu. The menu options in Flash Player 9
are Zoom In/Out, Show All, Quality (High, Medium, or Low), Play, Loop,
Rewind/Forward/Back, Settings, Print, Show Redraw Regions, Debugger,
and About Adobe Flash Player 9. Without this option, Settings, Show
Redraw Regions, Debugger, and About Adobe Flash Player 9 are the only
items on the shortcut menu. By default, Display Menu is selected.

Show Redraw Regions shows you the outlines of the regions of your
movie that Flash is currently refreshing.

v Device Font applies to Windows playback only. When this check box is
selected, the HTML file includes a DEVICE FONT parameter set to TRUE,
and Flash substitutes anti-aliased (smoothly curved) system fonts for
fonts not available on the viewer’s system. This applies only to static
text you create in Flash. By default, this item is not selected.
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Quality

The Quality section determines the quality parameter in the <object> and
<embed> tags of the HTML code. Quality refers to the level of anti-aliasing,
which means the smoothing of the artwork so that it doesn’t have jagged
edges. The lower the quality, the faster the playback. Usually, you want to
find a middle ground between quality and speed. You have six options:

v Low doesn’t use any anti-aliasing (and looks awful).

v Auto Low starts at a low quality but switches to a high quality if the
viewer’s computer, as detected by the Flash Player, can handle it.

v~ Auto High starts at a high quality but switches to a low quality if the
viewer’s computer can’t handle the playback demand. This option
should provide good results on all computers.

v Medium applies some anti-aliasing but doesn’t smooth bitmaps. This
option is a good middle ground between low and high. This setting is
the default.

v High always uses anti-aliasing for vector art. Bitmaps are smoothed only if
the file doesn’t contain tweens. (See Chapter 9 for the scoop on tweens.)

v Best always uses anti-aliasing, including for bitmaps.

Window Mode

Window Mode specifies how the player movie’s window interacts with the
rest of the page. Here are your options:

v Window plays your movie as an opaque rectangle within your Web page
and does not allow your HTML to render other content in that rectangle.
This is the default mode.

1 Opaque Windowless creates an opaque background for the movie so
that other elements in the Web page don’t show through when they’re
behind the movie. This setting does allow your HTML to render content
in front of the movie.

v Transparent Windowless makes the Flash background color transpar-
ent so that other elements on your Web page show through (or can
appear on top of) your Flash content. This setting might slow down
playback.

The code for the Transparent and Windowless modes has an effect only
in more recent browsers running on Windows or Mac OS X — Internet
Explorer version 5 and later, Netscape version 7 and later, Mozilla 1 and
later, Firefox 1 and later, and Opera 6 and later.
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HTML Alignment

The HTML Alignment setting specifies the ALIGN attribute and specifies how
the Flash Player movie is aligned within the browser window. You have five
options:

1 Default theoretically centers the Flash movie. If the browser window is
smaller than the movie, this option theoretically crops the edges of the
movie. But in our tests, the default is always left even though it should
be center.

v~ Left aligns the movie along the left side of the browser window. If the
window is too small, this option crops the other sides of the movie.

v+~ Right aligns the movie along the right side of the browser window. If
the window is too small, this option crops the other sides of the movie.

v Top aligns the movie along the top of the browser window. If the window
is too small, this option crops the other sides of the movie.

1 Bottom aligns the movie along the bottom of the browser window. If the
window is too small, this option crops the other sides of the movie.

Scale

The Scale setting defines how the movie is placed within the boundaries
specified by code in the HTML page when (and only when) you set a width
and height different from the movie’s original size, using the Pixels or Percent
options in the Dimensions section of the Publish Settings dialog box. You
have four options:

v~ Default (Show Al displays the entire movie without distortion but
might create borders on two sides of the movie.

The Show All setting shows all the elements in your Flash movie, even
those that you move to the sides, off the Stage.

v No Border scales the movie to fill the dimensions without distortion
but might crop portions of the movie.

v~ Exact Fit fits the movie to the dimensions, distorting the movie if
necessary.

v No Scale stops the movie from changing its scale if the viewer resizes
the Flash Player window.

Flash Alignment

Flash Alignment determines how the movie fits within the movie window
(as opposed to the browser window). It works together with the Scale and
Dimensions settings. In other words, it determines how the Flash movie fits
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within the dimensions you specify. For the Horizontal setting, you can choose
Left, Center, or Right. For the Vertical setting, you can choose Top, Center,
or Bottom.

Show Warning Messages

At the bottom of the Publish Settings dialog box is the Show Warning
Messages check box. When it’s selected, you see warning messages during
the publishing process. The publishing process continues, but you know that
you might have made an error. For example, if you've chosen a template that
requires a GIF or JPEG image but you haven’t selected either format on the
Formats tab, you see a warning message.

After you choose your settings, click OK to return to your movie or click
Publish to publish it.

Publishing to Other Formats

You can use Flash’s Publish Settings to generate files in a variety of other for-
mats besides HTML pages and Flash Player movies. These other formats are
GIF images, animated GIFs, JPEG images, PNG images, QuickTime movies, and
self-playing Windows and Mac projectors.

Even if you use Flash all day, every day, you might never need to generate
GIF images, JPEG images, or QuickTime images from your Flash movies,
so we won’t clog up your life by describing the Publish Settings for those
formats here.

Creating PNG graphic files

PNG files can display millions more colors than GIF files and support trans-
parency. They offer some of the advantages of both GIFs and JPEGs. To create
a PNG image, choose PNG Image on the Formats tab of the Publish Settings
dialog box (refer to Figure 13-2). Flash creates a PNG tab in the dialog box,

as shown in Figure 13-6.

Flash publishes the first frame of your movie unless you label a different
frame with the #Static label. (To create a label, click the frame and choose
Window=>Properties=>Properties to open the Property inspector. If necessary,
expand the Property inspector to its full size. Type a label name in the Frame
text box on the left side of the Property inspector.)
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|
Figure 13-6:
Use the

PNG tab to
create PNG
images.
|

Publish Settings

Current profile: | Bounce Publish Profile B Blr=e[F

Formats _ Flash | HTML | PNG }

Width: Height:
Dimensions: ¢ X E March movie

Bit depth: | 24-bit with Alpha _:I

| Dither solids

Uptions: @ Optimize colors

_lInterlace | Remove gradients

E‘ Smooth
Dither:
Palette Type:
Max colors:
Paletta:

Filter options: | None -4

(" Publish ) (Cancel ) € OK )

You have the following options:

v Dimensions lets you specify your own Width and Height settings if you
deselect the Match Movie check box. This could be useful if you want to
create a thumbnail image to use on a Web page to link to your movie. By
default, Flash matches the dimensions of the movie.

v~ Bit Depth controls the number of bits per pixel, which in turn means
how many colors the image contains. You can select 8-bit for 256 colors
(like a GIF), 24-bit for 16.7 million colors, or 24-bit with Alpha, which
allows for transparency. When you choose 24-bit with Alpha, the image’s
background becomes transparent. This is one of the things that design-
ers love about PNG files.

v Options specifies how the PNG file appears:

¢ Optimize Colors removes unused colors from the file’s color table
to reduce the size of the file.
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¢ Interlace causes a static PNG image to load in incremental resolu-
tions, so the image appears first fuzzy and then successively sharper.
Some people like this option because viewers may be able to click
the image before it fully downloads, thus reducing their waiting time.

¢ Smooth anti-aliases (smoothes) the artwork. Text usually looks
better (and the file size is larger), but occasionally you may get an
undesirable halo effect around your art. In that case, turn off
smoothing.

¢ Dither Solids does just that — it dithers solid colors as well as gra-
dients and images. Dithering is a way to approximate colors not
available on the color palette by using a range of similar colors.
This applies only to files with 8-bit color. See the Dither option,
which we describe a few paragraphs from now.

¢ Remove Gradients turns gradients into solids. Gradients may not
look good in a Web-safe color table. Nevertheless, Flash uses the
first color in the gradient, which may not be the color you want.

v~ Dither enables dithering for files with 8-bit color, as we define in the
Dither Solids bullet in the Options descriptions. Dithering helps to
create more accurate looking colors but increases file size. Choose
one of the three options:

¢ None disables dithering.

¢ Ordered provides a medium amount of dithering and a corre-
sponding medium increase in file size.

¢ Diffusion provides the best-quality dithering and increases file size
the most. It works only with the Web 216-color palette. (Refer to
Chapter 3 for a description of color palettes.)

v~ Palette Type determines the color palette for the PNG image. This
applies only to PNG files with 8-bit color. (Refer to Chapter 3 for a
discussion of colors in Flash.) You have four options:

e Web 216 uses the standard 216-color palette that includes only
Web-safe colors (those that look good on all Web browsers). You
can usually get good results for Flash artwork without increasing
file size.

e Adaptive creates a unique color table for your file, based on the
actual colors present. You get more accurate color (although these
colors may not be Web safe), but the file size may be larger. Use
this option if an accurate representation of the colors is most
important, as in a photographic bitmap image. You can use the
Max Colors text box to specify how many colors you want in the
table. The default is 255. Use fewer colors to reduce the file size.
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e Web Snap Adaptive works like the Adaptive option but optimizes
the color palette for the Web. Colors close to the 216 Web-safe
colors are turned into one of the colors on that palette. Other
colors function like the Adaptive option. As with the Adaptive
option, you can specify the number of colors on the palette in
the Max Colors text box.

e Custom lets you specify a palette in the ACT format. Click the file
folder icon near the Palette text field to browse for a color palette
file. (Read the section in Chapter 3 on solid colors for an explana-
tion of how to create a color palette and save it in ACT format.)

¢ The Max Colors option is enabled only when you choose Adaptive
or Web Snap Adaptive, and the Palette option is enabled only when
you choose Custom.

v Filter Options controls how an image is analyzed line by line to com-
press it. You have these options:

¢ None applies no filtering. The resulting file is larger than with the
other options.

¢ Sub filters adjoining pixel bytes (working horizontally). This works
best when the image has repeated horizontal information.

e Up filters in a vertical direction. This works best when the image
has repeated vertical information.

¢ Average uses a mixture of horizontal and vertical comparison; this
is a good first-try option.

e Path employs a more complex method that uses the three nearest
pixels to predict the next one.

¢ Adaptive creates a unique color table for your PNG file based on
the actual colors present. You get more accurate color, although
these colors might not be Web safe. The file size might also be
larger. Use this option if accurate representation of colors is most
important, as in a photographic bitmap image.

After you specify your settings, click OK to return to your movie or click
Publish to publish your PNG image and create the other files you’ve chosen.

Creating self-playing movies

You can also create projectors in the Publish Settings dialog box. A projector
is a self-playing Flash movie that doesn’t require the Flash Player. All the
interactive and animated features of your Flash movie work in a projector.
You can use a projector for a Flash movie that you want to burn on a CD-R
or DVD-R computer disc (The projector format is not compatible with the
format of a DVD movie disc, though.) Projector files tend to have much
larger sizes than their corresponding . swf files.



302 Part V: The Movie and the Web

You can create a Windows or Mac version from either platform. But if you
create a Mac version in Windows, you need to use a file translator, such as
BinHex so that the Mac Finder recognizes it as an application.

To create a projector, follow these steps:

1. Choose File=>Publish Settings.
The Publish Settings dialog box opens.

2. On the Formats tab, select the Windows Projector check box or the
Macintosh Projector check box, or both.

3. Click Publish.

4. Click OK or Cancel to close the Publish Settings dialog box.
For Windows, Flash creates an EXE file. For the Mac, Flash creates a Macintosh
Projector application. If you create the Macintosh Projector file in Flash while

using a Windows computer, the Macintosh Projector file is stored inside a
compressed BinHex file (HQX), which can then be uncompressed on a Mac.

Don’t forget to test your movie after you copy it to a CD-ROM or another
computer. Try it out with a variety of processor speeds if possible.

Using Publish Profiles

You can save all the settings that you configure in the Publish Settings dialog
box as a publish profile. You can then duplicate, modify, export, import, and
delete your publish profiles and trade them with your collaborators. You can
create standard publish profiles, which you use to make sure that all your
files are published uniformly, and you can create specialized publish profiles
specific to a single project. The following sections tell you how.

Creating a publish profile
To create a publish profile, follow these steps:

1. Choose Filez>Publish Settings.
The Publish Settings dialog box appears.

2. Click the Create New Profile button (the + symbol) in the upper-right
part of the dialog box.

The Create New Profile dialog box appears.
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3. Type a name for your profile and then click OK.

The Create New Profile dialog box disappears, and the name of your new
profile appears in the Current Profile drop-down list of the Publish
Settings dialog box.

4. Specify the publish settings for your document in the Publish Settings
dialog box, as we describe in earlier sections of this chapter, and then
click OK.

Duplicating or renaming a publish profile
You might want to duplicate a publish profile to use it as a springboard for
new variations. To duplicate a publish profile, do the following steps:
1. Choose File>Publish Settings.
The Publish Settings dialog box appears.

2. In the Current Profile drop-down list (near the top of the dialog box),
select the publish profile that you want to rename (or copy).

3. Click the Rename Profile button (or the Duplicate Profile button — the
horizontal arrow button), in the upper-right part of the dialog box.

The Profile Properties dialog box (or the Duplicate Profile dialog box)
appears.

4. Type a new name for your profile (or the name for your duplicate
profile) and then click OK.

The dialog box disappears. The name of your renamed profile (or your
duplicate profile) appears in the Current Profile drop-down list of the
Publish Settings dialog box.

Modifying a publish profile

You might use a particular publish profile as, for example, a standard for your
co-workers. As circumstances change, you might want to modify the publish
profile, and that’s easy to do. To modify a publish profile, follow these steps:

1. Choose File=>Publish Settings.

The Publish Settings dialog box appears.

2. In the Current Profile drop-down list (near the top of the dialog box),
select the publish profile that you want to modify.

3. Select the publish settings that you want for your document in the
Publish Settings dialog box, as we describe in the earlier sections
of this chapter, and then click OK.
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Deleting a publish profile
To delete a publish profile, follow these steps:

1. Choose File=>Publish Settings.
The Publish Settings dialog box appears.

2. In the Current Profile drop-down list (near the top of the dialog box),
select the publish profile that you want to delete.

3. Click the Delete Profile button (the trash can) in the upper-right part
of the dialog box.

A dialog box appears asking you to confirm that you want to delete the
profile.

4. Click OK.

Exporting and importing publish profiles

To use a publish profile in documents other than the document in which you
created it, first you export it from the document in which you created it.
Then you import it into the new document.

This makes your work easier if, for example, you’re working on a Flash pro-
ject with a team and need to publish your Flash documents according to a
single standard. The entire team can easily share the same publish profile.

To export a publish profile, follow these steps:

1. Choose File=>Publish Settings.
The Publish Settings dialog box appears.

2. In the Current Profile drop-down list (near the top of the dialog box),
select the publish profile that you want to export.

3. Click the Import/Export Profile button (the vertical arrow button in
the upper-left part of the dialog box) and select Export in the drop-
down list.

The Export Profile dialog box appears.

4. In the dialog box, select a location where you want to save the file and
then click Save.

The default location is a folder named Publish Profiles, which is located
in the Flash CS3 application folder. The file is saved as an .xm1 file.
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To import a publish profile, follow these steps:

1. Choose Filez>Publish Settings.
The Publish Settings dialog box appears.

2. Click the Import/Export Profile button (the vertical arrow button in
the upper-left part of the dialog box) and then select Import in the
drop-down list.

The Import Profile dialog box appears.

3. In the dialog box, browse to find the publish profile that you want to
import and then click Open.

The name of the imported publish profile appears in the Current Profile
drop-down list of the Publish Settings dialog box.

Using Publish Preview

If you want to specify publish settings, see the results, and then go back to
tweak your settings, you can use Publish Preview rather than Publish. Publish
Preview creates the files specified in the Publish Settings dialog box, just as
the Publish command does. The only difference is that Publish Preview auto-
matically displays the requested file, usually the . swf file. The value is in
simply saving the steps of manually opening your files in your browser —
helpful when you’re doing lots of tweaking and going back and forth between
your publish settings and your browser to see what works best.

To use Publish Preview, follow these steps:

1. Specify your settings by using the Publish Settings dialog box (as we
explain earlier in this chapter) and then click OK.
2. Choose Filez>Publish Preview.

3. In the Publish Preview submenu, choose the file format that you want
to preview.

4. When you’re finished, close the window or browser.

Posting Vour Movie to Vour Web Site

After you finish publishing your movie, you probably want to post your . swf
file on your Web site or place it on a CD-R or other media.
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You can make Mac and Windows projectors and copy them onto a CD-R by
using CD-burner software. Then you can view your Flash movie indepen-
dently of a Web browser. Or copy your published HTML and . swf files onto a
CD-R along with any external scripts, image files, or text files used by your
HTML and . swf files.

Refer to the “Understanding the HTML code for a movie” section, earlier in
this chapter, for instructions on modifying the HTML code if you want to place
your . swf file on an existing Web page or place your . swf file in a subfolder.

To post your movie to a Web site, upload the HTML, the . swf file, and the
JavaScript file.

The default HTML file that Flash generates when you publish a Flash movie
depends on an external JavaScript file that Flash generates along with it.

If your HTML or . swf files load data from any image files, text files, or exter-
nal scripts (such as JavaScript or ActionScript files), you need to upload
those, too.

Open your browser and load the Web page that contains your Flash movie.
We hope it works perfectly and looks great! If not, check out the HTML code,
check your publish settings, and make sure that the necessary files are in the
proper location on your Web site’s server.

Exporting Movies and Images

In addition to publishing, Flash lets you export image files and QuickTime
movies. Export a Flash file when you want to use it in another application.
For example, you may want to export a frame as a PNG file and insert it into
a word processing document. You can use Export Movie to export to a
QuickTime movie or to create a still image of every frame.

After you export a movie or image, you can then import it into the desired
application for further editing or display.

Note that when you choose File>Export=>Export Movie to export a movie

to a format such as GIF, JPG, or PNG, you export a sequence of individually
numbered images. That might give you some interesting raw material to
import into other graphics applications. In fact, exporting a Flash movie as a
PNG sequence is how many professional animation jobs are now done. The
sequence of PNG files is then imported into Adobe After Effects to be con-
verted to Cineon files, which are used to put the animation onto movie film.
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To export a movie or image, follow these steps:

1. Open the Flash document from which you want to export.

See Chapter 1 for information about opening an existing Flash movie.

2. To export to an image, select the frame that you want to export.

Otherwise, skip to Step 3.

3. Choose File>Export>Export Image or Filem>Export~>Export Movie.

4. In the dialog box, navigate to the desired location and type a name for

your image or movie.

5. In the Save as Type (Format on a Mac) drop-down list, select the type

of file.

6. Click Save.

7. Depending on the format that you selected, a dialog box might

appear. If so, specify the settings and then click OK.

These settings are similar to the kind of settings that we describe earlier
in this chapter, in the “Creating PNG graphic files” section.

Table 13-2 lists the types of files that you can export.

Table 13-2 Export File Types

File Type Windows Mac Comments

Adobe lllustrator (Al) X X A vector format.

Drawing Exchange X X A format that you can import into

Format (DXF) AutoCAD, although you lose fills.

Encapsulated X X A vector format used in Adobe

PostScript (EPS) lllustrator and recognized by many
other applications.

Graphics Interchange X X A bitmap format, limited to 256 colors.

File (GIF)

Joint Photographic X X A bitmap format that supports 24-bit

Experts Group color.

(JPEG/JPG)

Flash Video (FLV) X X A video format designed for use with

video conferencing and other com-
munications applications.

(continued)



308 Part V: The Movie and the Web

Table 13-2 (continued)
File Type Windows Mac Comments
PICT (PCT) X A bitmap format that can be used

with most Mac and many PC applica-
tions. The PICT format supports
transparency and variable bit depths.

Portable Network X X A bitmap format that supports

Graphic (PNG) variable bit depths and transparency.

QuickTime (MQOV) X X A QuickTime 4 format movie.

QuickTime Video X On Macs only, uses the Video

(Mov) QuickTime 3 format, bitmapping all
content.

Video for Windows X A bitmap video format. Files can get

(AVI) large.

Windows Audio X Exports just the sound.

(WAV)

Windows Bitmap X A bitmap format. Many applications

(BMP) recognize it. Offers variable bit
depths and transparency support.
File size is large.

Windows Metafile X A vector format supported by many

and Enhanced

Metafile (WMF/EMF) applications.
Creates smaller files than EPS.

Creating Printable Movies

Suppose that you want your Web site viewers to be able to print a form on

your Web site that you created in Flash. Or perhaps you want them to print
your contact information so that your Web page can become your business
card. The Flash Player printing features enable your viewers to print receipts,
information sheets, coupons, or whatever else helps you do business on the
Web. You can specify certain frames in a movie — including frames in the
main Timeline, a button, or a movie clip — to be printable from the Flash
Player shortcut menu. Viewers right-click (Windows) or Control+click (Mac)
to access the Print command.
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Your viewers need instructions on how to print, so place some text some-
where telling them what to do.

Of course, viewers can use their browser’s Print command to print, but

the result isn’t nearly as controllable. When we tried it, our browser printed
only the first frame, which was useless in our example. The browser also
added the Uniform Resource Locator (URL), the name of the movie, the date,
and the page number.

By default, the Flash Player shortcut menu lets viewers print the entire
movie, frame by frame. This feature is useless for most purposes. But by
specifying which frames are printed and the print area, you can use the
Player’s Print command to make specific information or forms available to
your viewers.

Preparing your movie for printing

If you want a nice, clean result, you need a nice, clean frame. The Flash Player
prints all objects on all layers of the movie. If you want to create a form, for
example, put it in its own frame and make sure that objects on other layers
don’t continue into that frame.

Alternatively, you can specify the print area so that you include only the area
that you want printed, excluding other objects on the Stage in the frame. But if
you specify a small area, this area becomes the entire page size when printing,
so the objects in that small area are enlarged to take up the entire printed
page. You can control the layout by changing the dimension, scale, and align-
ment HTML settings (on the HTML tab of the Publish Settings dialog box).

Make sure that everything you want to print is on the Stage. For example, if
you want to print from a movie clip, it must be on the Stage and have an
instance name.

You can make a movie clip invisible by setting its _visible property to
false. (Use the Actions panel.) This capability enables you to instruct view-
ers to print an item that they don’t see on the screen — for example, a form
that’s formatted differently on paper and on the computer screen.

If your movie displays text instructing users how to print from the printable
area, you might want to exclude this text from the printable area. They prob-
ably don’t want to print the instructions on how to print, right?
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Specifying printable frames

To specify which frame or frames you want to print when your viewers
choose Print in the Flash Player shortcut menu, follow these steps:

1. With the movie open, choose Window=>Properties=>Properties to
open the Property inspector.

The shortcut is Ctrl+F3 (Windows) or 88+F3 (Mac). If necessary, expand
the Property inspector to its full size.

2. Select from the Timeline the frame you want printed.

3. If the frame you selected is not a keyframe, make it a keyframe by
choosing Insert~>Timeline~>Keyframe.

Turn to Chapter 9 for the lowdown on keyframes.

4. In the Property inspector, type #p in the Frame text box, as shown in
Figure 13-7. Below the Frame text box, set the Label Type drop-down
list to Name (the defaulf).

Figure 13-7:
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For each additional keyframe that you want to specify for printing, select the
frame and then label it #p in the Property Inspector Frame text box.

Specifying the print area

Unless you specify the print area, the Flash Player prints the entire Stage. If
you have loaded other movies, the Flash Player uses their Stage size. You
might, however, want to specify a different area. As we mention earlier in this
chapter, you might want to include instructions on how to print, but you may
not want the instructions to be printed. You can exclude other objects on the
Stage as well.
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Choosing a very small print area results in an output of very big objects. The
Flash Player sizes your objects to take up the entire printed page.

You create an object, usually a rectangle, to specify the print area. To specify
the print area, follow these steps:

1.

Click a frame that you have labeled #p (as we describe in the preced-
ing section).

. Create a rectangle around the area that you want to be printed.

You might have to experiment with different sizes of rectangles. See the
instructions in the section “Printing movies from the Flash Player,” a
little later in this chapter, to test the printing of your movie.

Use the No Fill feature for the rectangle so that you can see the material
that you want to print.

3. Select the rectangle and choose Edit=>Cut to cut it to the Clipboard.

4. Click a frame without a #p label but on the same layer.

Using the next frame might be a good choice to keep the printing area
rectangle conveniently close to the frame you’ve specified for printing.

. Choose Edit=>Paste in Place.

You now have a rectangle of the right size, but in its own frame — a
frame without a #p label.

. Select the frame containing the rectangle and choose

Window=>Properties=>Properties to open the Property inspector.

If necessary, expand the Property inspector to its full size.

. In the Frame text box on the left side of the Property inspector, type

#b to signify that the shape in this frame will be used as the boundary
for the print area.

You can have only one #b label in a Timeline. Also note that if you use a
#b label, it must be on the same layer as the #p label.

Printing movies from the Flash Player

Before uploading your printable movie to your Web site, you should test the
printing function. To do so, use the Publish Settings dialog box to specify the
publish settings that you want, as we explain throughout this chapter. Then
choose Filem>Publish Previewr>Default. Your browser opens, and you see your
movie play.
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To test-print your movie, right-click (Windows) or Control+click (Mac) in the
browser. In the Flash Player shortcut menu, choose Print.

On the Mac, the Page Setup dialog box appears; choose the printer, paper
size, orientation, and scale, and then click OK.

Then for both Mac and Windows, the Print dialog box appears. Choose the
print range to select which frames to print or choose All. In Windows, you
can also choose Selection to print the current frame. If only one frame has
been made printable, the Pages option appears dimmed. Any option that you
choose prints the frame you’ve specified for printing. Click OK (Windows) or
Print (Mac) to print.

After you upload your movie onto your Web site, viewers use the same proce-
dure to print your movie.

& Place on your page some text that explains to your viewers how to print your
movie. Many viewers don’t even know that the shortcut menu exists.





